Intermitted Network Connectivity Issues
Resolved
Mar 27, 2026 at 03:48pm UTC
Dear Valued Paysoft Client,
Please be advised that the network connectivity outage has been resolved.
Should you experience any further issues, please contact our support team:
Telephone: 021 551 0891
Email: support@paysoft.co.za
Kind Regards,
Paysoft Support Team
Paysoft (Pty) Ltd
Affected services
Created
Mar 27, 2026 at 01:00pm UTC
Dear Valued Paysoft Client,
Please be advised that we are currently experiencing a network connectivity outage with one of our providers which may be impacting your payment processing, transaction settlements, and API integrations.
Our team has formally escalated the matter and is working diligently with our providers to investigate and resolve it. We are monitoring the situation closely.
We sincerely apologize for any disruption to your services and appreciate your patience and understanding during this time.
For immediate assistance, please contact our support team:
Telephone: 021 551 0891
Email: support@paysoft.co.za
Kind Regards,
Paysoft Support Team
Paysoft (Pty) Ltd
Affected services